Hi.

Welcome to the Essential Apple website. We hope you enjoy your stay and please feel to contact us if you so desire.

iTunes 12.2 Needed For Beats 1 But Missing In Action

iTunes 12.2 Needed For Beats 1 But Missing In Action

1435688035_featured.jpeg

When I try to sign up for Apple Music, it says I need iTunes 12.2 but when I click the download link it takes me to iTunes 12.1.

So the earlier upgrade to iOS 8.4 for Apple Music worked well but it seems that there are some issues, namely with iTunes 12.2. Despite checking software update only iTunes 12.1.2 is available for a download at the moment.

Adding to the confusion at the bottom of the present version of itunes you can see

Apple Music
90-Day Trial
Beats 1
Radio

So lets click on the 90-Day Trial.

Requires iTunes 12.2 or later.

Ok that’s fair enough but if you follow the link, see if you can spot the problem….

iTunes 12.1.2 Download Instead of 12.2 Download

Beats 1 does the same as above but when you click on Radio, things start to get a touch strange.

iTunes 12.2 Radio Is not Supported In Country Or Region

iTunes 12.2 Now Available Via App Store

iTunes 12.2 Now Available Via App Store

Missed The Apple Music Beats 1 Launch?

Missed The Apple Music Beats 1 Launch?